After upgrading to RSA NetWitness Logs and Network 11.x, the host's status is stuck at 'Rebooting'
Issue
After successfully upgrading a host to NetWitness 11.x, the NW UI shows the host's status as 'Rebooting' under ADMIN-Hosts as shown below.
Rebooting the host does not change the status.
Other than 'Rebooting' status, no apparent issue is noticed for the host or the services.
Cause
The issue can occur when 'appliance_update' collection in 'sa' database is not updated with the correct status.
Resolution
Please perform the following steps to resolve the issue.- SSH to each of the host\s showing as rebooting in the UI
- Note the node ID
cat /etc/salt/minion - SSH to the NW Admin Server (nw-node-zero)
- Log in to the mongo db as deploy_admin user
mongo admin -u deploy_admin -p
Note: Replacewith the actual password.
- Show available databases and change to use 'sa'.
> show dbs
...
sa xGB
...
> use sa
switched to db sa
- For each host showing rebooting, replace
with the one noted from step #2.
>db.appliance_update.update({ "_id" : "" }, { $set: { status : "REBOOTED", acceptWarning : false}})
e.g.
>db.appliance_update.update({ "_id" : "992dcb11-39c2-4c11-b9c9-7f5e98f3c111" }, { $set: { status : "REBOOTED", acceptWarning : false}})
The following result is expected for successful execution.
WriteResult({ "nMatched" : 1, "nUpserted" : 0, "nModified" : 0 })
>exit
- Log in to the NW Admin Server UI and confirm the status of each host.
Product Details
RSA Product Set: NetWitness Logs & NetworkRSA Product/Service Type: Admin Server, UI
RSA Version/Condition: 11.X
Platform: CentOS 7
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