How to reinitialize RSA Netwitness Malware Analysis DB
Issue
Customer wants to reinitialize Malware Analysis DB as the customer is not able to start up the service properly due to broken DB table or data.
Cause
The customer deleted DB files under /var/lib/pgsql or spectrum database accidentally.
Resolution
Background : The customer cannot start up Malware Analysis service due to corrupted DB. As the step requires reinstallation of the Malware Analysis package on OS level, the proper YUM repository should be prepared in advance.This step will REMOVE all the current data(previous analysis results on DB) on Malware Analysis and reinitialize all the database and tables for MA. It will take less than 10 min to complete except the Optional step.
- SSH to Malware Analysis
- # stop rsaMalwareAnalysis
- # mkdir /root/MAbackup/
- # cp /var/lib/rsamalware/spectrum/logs /root/MAbackup : Backup spectrum.log for troubleshooting purpose just in case
- # cp /var/lib/rsamalware/spectrum/conf /root/MAbackup : Backup configuration files for restore
- (Optional) If you want to backup repository files, please backup /var/lib/rsamalware/spectrum/repository.
- # rm -rf /var/lib/pgsql/*
- # service postgresql-9.1 initdb
- # yum reinstall rsaMalwareDevice : Make sure it will reinstall the same version before the start. As part of the installation process, spectrum database will be reconfigured.
- # stop rsaMalwareAnalysis
- Restore the configuration from /root/MAbackup/conf
- # start rsaMalwareAnalysis
- Set proper time boundary
- Log in Netwitness UI
- Navigate to Administration > Service > Malware Analysis > Config
- Set proper value for Time Boundary
- Enable continuous analysis
Product Details
RSA Product Set: NetwitnessRSA Product/Service Type: Malware Analysis
RSA Version/Condition: 10.3, 10.4, 10.5, 10.6
Platform: CentOS
O/S Version: 6
Approval Reviewer Queue
ASOC Approval Group