NetWitness License response fails to upload under the License Setting tab
Issue
When uploading the license response bin file into the NetWitness Licensing area within the NetWitness UI, a general error of, "
Cause
The License server can fail to upload the response.bin files in certain cases because the flexnet running files, " flexnetls_licenses.ks , flexnetls_licenses.mv.db, flexnetls.pn, and RSALM.0" have become corrupted.
Resolution
The steps below will be applied to the Admin-Server/NW-NODE-ZERO and completely reset the licensing files and allow for a successful response bin upload.
- Stop the following services on the Admin Server
# systemctl stop flexnetls-RSALM
# systemctl stop rsa-nw-license-server
- With the services stopped. Remove the following files.
# cd /etc/netwitness/flexnetls
# rm flexnetls*
# rm RSALM.0
# cd /tmp
# rm fne*
- Start all stopped services
# systemctl start flexnetls-RSALM
# systemctl start rsa-nw-license-server
- Once all the services have restarted, the files that were removed in previous steps will be regenerated.
- Attempt to upload the license response bin file once more.
- If you are still experiencing an issue, please open a NetWitness Support case.
Product Details
NetWitness Product Set: NetWItness Logs and Network
Product/Service Type: Admin server/Node-zero
NetWitness Version/Condition: 12.4+
Platform: AlmaLinux
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