Skip to content
  • There are no suggestions because the search field is empty.

NetWitness License response fails to upload under the License Setting tab

Issue

When uploading the license response bin file into the NetWitness Licensing area within the NetWitness UI, a general error of, " " occurs. When looking in the flexnetls-RSALM.log, under , the following appears: " License response fails trust criteria".


Cause

The License server can fail to upload the response.bin files in certain cases because the flexnet running files, " flexnetls_licenses.ks , flexnetls_licenses.mv.db, flexnetls.pn, and RSALM.0" have become corrupted. 


Resolution

The steps below will be applied to the Admin-Server/NW-NODE-ZERO and completely reset the licensing files and allow for a successful response bin upload.

  1. Stop the following services on the Admin Server
# systemctl stop flexnetls-RSALM

# systemctl stop rsa-nw-license-server
  1. With the services stopped. Remove the following files.
# cd /etc/netwitness/flexnetls
# rm flexnetls*
# rm RSALM.0

# cd /tmp
# rm fne*
  1. Start all stopped services
# systemctl start flexnetls-RSALM

# systemctl start rsa-nw-license-server
  1. Once all the services have restarted, the files that were removed in previous steps will be regenerated.

  2. Attempt to upload the license response bin file once more.

  3. If you are still experiencing an issue, please open a NetWitness Support case.

Product Details

NetWitness Product Set:  NetWItness Logs and Network

Product/Service Type: Admin server/Node-zero 

NetWitness Version/Condition: 12.4+

Platform: AlmaLinux


Approval Reviewer Queue

Technical approval queue