Skip to content
  • There are no suggestions because the search field is empty.

NetWitness Log Collector ODBC test connection failing

Issue

When ODBC test connection checked using How to test an ODBC connection from a Log Collector in RSA Security Analytics / NetWitness Platform  below error throws.
Error! An error occurred creating an ODBC connection for DSN: DBname The trapped error is: Unable to create an ODBC connection. DSN: DBname; username: odbcuser; reason: state: 103; error-code: 0; description: [RSA][ODBC 20101 driver]252


 

Cause

This issue is due to Installation directory details missing in odbc.ini file.


Resolution


Please follow the below steps to resolve the issue.
  1. Login SSH of Log Collecotr and Stop Log Collector service using the below command.
    systemctl stop nwlogcollector.service
  2. Take a backup of the existing /etc/netwitness/ng/odbc.ini file.
    cp /etc/netwitness/ng/odbc.ini /root/odbc.ini
  3. Edit /etc/netwitness/ng/odbc.ini file to include the below section.
    [ODBC]
    InstallDir=/opt/netwitness/odbc
    sample file contents:
    [ODBC]
    InstallDir=/opt/netwitness/odbc

    [MFA_SIEM]
    Database=DBname
    PortNumber=1433
    HostName=10.10.10.10
    Driver=/opt/netwitness/odbc/lib/R3mysql27.so


     
  4. Start Log Collector service using below command and verify test connection.
systemctl start nwlogcollector.service


Product Details

NetWitness Product Set: NetWitness Platform
NetWitness Product/Service Type: LogCollector
NetWitness Version/Condition: 12.x
Platform: CentOS 7 / Alma


Summary

This document outlines the process to ODBC test connection error.


Approval Reviewer Queue

Technical approval queue