NetWitness Log Collector ODBC test connection failing
Issue
When ODBC test connection checked using How to test an ODBC connection from a Log Collector in RSA Security Analytics / NetWitness Platform below error throws.
Error! An error occurred creating an ODBC connection for DSN: DBname The trapped error is: Unable to create an ODBC connection. DSN: DBname; username: odbcuser; reason: state: 103; error-code: 0; description: [RSA][ODBC 20101 driver]252
Cause
This issue is due to Installation directory details missing in odbc.ini file.
Resolution
Please follow the below steps to resolve the issue.
- Login SSH of Log Collecotr and Stop Log Collector service using the below command.
systemctl stop nwlogcollector.service
- Take a backup of the existing /etc/netwitness/ng/odbc.ini file.
cp /etc/netwitness/ng/odbc.ini /root/odbc.ini
- Edit /etc/netwitness/ng/odbc.ini file to include the below section.
[ODBC]sample file contents:
InstallDir=/opt/netwitness/odbc[ODBC]
InstallDir=/opt/netwitness/odbc
[MFA_SIEM]
Database=DBname
PortNumber=1433
HostName=10.10.10.10
Driver=/opt/netwitness/odbc/lib/R3mysql27.so
- Start Log Collector service using below command and verify test connection.
systemctl start nwlogcollector.service
Product Details
NetWitness Product Set: NetWitness PlatformNetWitness Product/Service Type: LogCollector
NetWitness Version/Condition: 12.x
Platform: CentOS 7 / Alma
Summary
This document outlines the process to ODBC test connection error.
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