NetWitness Precheck - YUM Proxy Check Errors on Node-X servers Only
Issue
The Precheck tool fails with the below error message:
This probe checks for the existence of the yum.conf file and the presence of a proxy within the file.
Cause
The system upgrade fails if the proxy is present and enabled on any Node-X in the file /etc/yum.conf.Sample screenshot for the same:
To ensure that upgrades and installations proceed smoothly, it is necessary to remove any proxy settings beforehand. This is because the process relies on receiving accurate responses to multiple API calls, which can misfire if a proxy is set up. After the upgrade or installation is complete, custom proxy settings can be re-added.
Resolution
1. SSH to the individual Node-X host where the proxy is configured.2. Navigate to the /etc/yum.conf file and remove the proxy information. Follow these steps to remove the proxy information:
a) vi /etc/yum.conf and press i to get into insert mode.
b) Remove the following lines:
b) Remove the following lines:
proxy= <porxy_URL>
proxy_username=<proxy_username>
proxy_password=<proxy_password>
proxy_username=<proxy_username>
proxy_password=<proxy_password>
c) Save the changes.
3. After saving file without proxy entries, precheck tool shows success for Yum Proxy Check probe. Sample screenshot for the same:
Notes
If looking for how to address the YUM Proxy error for the Admin server (Node0), please following the below link:https://community.netwitness.com/t5/netwitness-knowledge-base/netwitness-precheck-yum-proxy-check-error-for-node0-admin/ta-p/709030
Product Details
RSA Product Set: NetWitness PlatformRSA Product/Service Type: All nodes
RSA Version/Condition: 12.4 or later
Platform: CentOS
Summary
This knowledge base article is for addressing YUM proxy errors on Node-X servers only. If the error being seeing is for the Admin server (Node0), please see the Notes section for a link to the knowledge base article that addresses that issue.
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