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How to fix when incorrect PSU status on H&W found when actually one PSU is failed on NetWitness S5 Hybrid

Issue

Can not detect Power Supply Unit failure for Series 5 Hybrids even if the Power Supply Unit is actually failed situation. 
  1. During failure tests, we pull one side of power cables out from the following appliances;
    NW server
    ESA
    Network Hybrid-1
    Network Hybrid-2
     
  2. Health&Wellness SNMP alerting for the NW server and the ESA were successful, but both of the Hybrids didn’t. (refer to the following screenshot)
    User-added
  3. Checking the hardware status from iDRAC like the following screenshot. those PSs in the Hybrids which were being disconnected showed the correct as bad status in the Hybrids.
     User-added
     
  4. Tried to connect and disconnect the power cable repeatedly. But the status of the PSs of Hybrids in Health & Wellness had the same which is just "ok" values, no matter what the power cable was connected to the Hybrid or not. and no luck even after services/OS restarted.

Cause

Issue was with the nwsysinfo.py, where the supported hardware lists were just limited to Series 4, Series 4s, Series 5, Series 6 that's why the PSU stats were correctly shown only for these type of hardware, currently added support for all the hardware types including Hybrids.


Resolution

Use the attached nwsysinfo.py copy to this location  /usr/lib/collectd/python/nwsysinfo.py on Hybrid and restart collectd as a workaround.

When copying the new nwsysinfo.py, make a backup of the existing nwsysinfo.py, MOVE it to a different location (not under the same directory) and also delete the existing nwsysinfo.pyc file before restarting collectd for changes to take effect.

Product Details

RSA Product Set: NetWitness
RSA Product/Service Type: Health and Wellness
RSA Version/Condition:11.2

Approval Reviewer Queue

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