RSA NetWitness Platform UI displays 'Error: HTTP 503' due to the hostname containing non-alphanumeric characters
Issue
RSA NetWitness UI displays "Error: HTTP 503" due to the hostname containing non-alphanumeric characters.When attempting to access the NetWitness UI, the browser displays the following error:
HTTP Error: 503
Problem accessing/. Reason:
Service Unavailable
Problem accessing/. Reason:
Service Unavailable
The /var/lib/netwitness/uax/logs/sa.log reports an error similar to the following:
[main] ERROR org.springframework.web.servlet.DispatcherServlet - Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'gzipResourceHttpRequestHandler' defined in ServletContext resource [/WEB-INF/mvc-servlet.xml]: Cannot resolve reference to bean 'buildInfo' while setting bean property 'buildInformation'; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'buildInfo'
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'gzipResourceHttpRequestHandler' defined in ServletContext resource [/WEB-INF/mvc-servlet.xml]: Cannot resolve reference to bean 'buildInfo' while setting bean property 'buildInformation'; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'buildInfo'
Cause
This issue can be caused due to the hostname containing non-alphanumeric characters, such as "_" , "." , "#", etc.
Resolution
In order to resolve the issue, refer to the following KB article
https://community.netwitness.com/t5/netwitness-knowledge-base/how-to-change-hostname-in-rsa-netwitness-platform-11-3-x-12-2-x/ta-p/677493.
- Remove any non-alphanumeric characters from the hostname.
- Make sure your /etc/hosts, /etc/sysconfig/network and /etc/hostname files are set correctly and reflect the new hostname.
- Reboot your appliance and the NetWitness UI should begin functioning normally after it fully initializes.
If you are unsure of any of the steps above or experience any issues, contact RSA Netwitness Support and quote this article ID for further assistance.
Internal Comments
UserName:shurtj10/14/2014 4:24:40 PM - Technically Reviewed
Technically reviewed the article and changed its status to Copy Edited. Changed the partition from RSA NetWitness to RSA Security Analytics. Modified statements and applied formatting to abide by Primus best practices.
Product Details
RSA Product Set: NetWitness Logs & NetworkRSA Product/Service Type: NW Server
RSA Version/Condition: 10.6.x, 11.x, 12,x
Platform: CentOS 6/7
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