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Uploading the Offline Capability Response fails when applying to the NetWitness Admin Server

Issue

After downloading the Offline Capability Response .bin file from the Download Central License Portal, any attempts to upload the file via the NetWitness UI results in an error message resembling:
image.png


The resulting error message will appear in the /var/log/netwitness/license-server/license-server.log file located on the Admin Server (NW-NODE-ZERO):
 

2024-05-02 14:23:32,510 [unchMessageListenerContainer-9] WARN API|Failure /rsa/license/set-capability-response [counter=1 reason=EntitlementException::HttpStatusCode: 400, HttpStatus: , Capability response host ID does not match. Expected 000C29B38958/Ethernet, got E4434B2223B6/Ethernet: Capability response host ID does not match. Expected 000C29B38958/Ethernet, got E4434B2223B6/Ethernet]

Cause

The issue occurs because the wrong hostId value has been entered for the created server in the  https://my.netwitness.com website.
For example getting the B or 8 character mixed, or using lowercase characters (must be uppercase), or not setting the ID Type to ETHERNET.
 


Workaround

Generate a new License Server on my.rsa.com:

  1. Go back to the my.netwitness.com  site and find the entry for the incorrect hostid, then Remove Add-Ons (all).
  2. Create Server with a new alias and enter the correct hostid for License Server Id and choose ID Type as ETHERNET.
  3. Map Add-Ons to the new alias, and obtain a new Download Capability Response file.
  4. Upload it to the NW Admin Server and ensure it is applied successfully.

Resolution

To resolve the issue, follow the steps below.

  1. Check the log file /var/log/netwitness/license-server/license-server.log for the hostId been used, as shown below.
     
    [root@NEW-NW11-NW-NODE-ZERO license-server]# grep "host ID does not match" /var/log/netwitness/license-server/license-server.log
    2024-05-02 14:23:32,510 [unchMessageListenerContainer-9] WARN API|Failure /rsa/license/set-capability-response [counter=1 reason=EntitlementException::HttpStatusCode: 400, HttpStatus: , Capability response host ID does not match. Expected 000C29B38958/Ethernet, got E4434B2223B6/Ethernet: Capability response host ID does not match. Expected 000C29B38958/Ethernet, got E4434B2223B6/Ethernet]

     
  2. Verify that the entry  ETHERNET={value} matches the value shown in the NetWtiness UI under Administration -> System -> Info -> License Server ID.

Internal Comments

UserName:shurtj
8/27/2014 7:54:19 PM - Technically Reviewed
Technically reviewed the article and changed its status to Copy Edited. Made modifications to abide by Primus best practices and validated the procedure.

Evan Pols -- 2 May 2024
Updated title, applies to, naming conventions, log locations, added new screenshots and log snippets. Moved Cause to a new location and resolution to a new location.

Product Details

NetWitness Product Set: NetWitness Platform
NetWitness Product/Service Type: Admin Server, Licensing
NetWitness Version/Condition:11.x,12.x
Platform: CentOS 7 / Alma

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